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ABOUT RELEASE NOTES AND OTHER DOCUMENTATION 
Use release notes to find out about new functions or enhancements to existing functions for 
this release. 
 
For more details about all functions, use the product’s Help documentation (Help>Help 
Topics, or press ALT+F1). 
 
For documentation that focuses on task-oriented needs, use the tutorials. These are available 
in the product’s Help system (Help>Tutorials). 
 
The web site has other product and company information (www.kubotekusa.com).  
 

NOTE TO WINDOWS VISTA USERS: You must install a file to read KeyCreator 
Help. See “Important Requirement for Windows Vista Users” on page 23. 

 
 A vertical bar on the left side of the page indicates a change for Release 7.0.1 compared 
with Release 7.0. 
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NEW FUNCTIONS 
T his release adds the new functions explained below. 

New Print Function for Batch Printing 
Location: File>Batch Print Part 
This new File function allows you to print one or more selected viewports or layouts. (You 
can display multiple viewports using the View>Viewport Layout function. You can have 
multiple layouts using the Layout>Layout Dialog>New function.) When there is only one 
viewport and no layout, File>Batch Print Part has the same function as File>Print. 
 
The dialog box for the Batch Print Part function has the same elements on it as the standard 
print dialog has (File>Print), except for the elements in the boxed areas on the following 
figure. 
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Light Direction Added to View Menu 
Location: View>Render>Light Direction. This release adds the Light Direction function. 
This function allows you to control the direction of light shining on a shaded model to give 
the effect you desire. 
 
See the two figures below, which illustrate before and after applying this function. The 
function lets you change the light direction either by entering values in the X, Y or Z fields 
on the Camera Light dialog, or by moving the "modifier" with the mouse. Then click 
Accept on the Conversation bar to apply. (Moving along the x-axis always moves in the 
horizontal direction, moving along the y-axis always moves in the vertical direction, and 
moving along the z-axis always moves in the depth-direction.)       
 
Before: 
 
 
 
 
   
  
 

 

 

 
After: 

 

Modifier 
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Function Added that Bends a Corner 
Location: Create>Solid Feature>Auto Bend Corner. This function allows you to change 
a solid body's corner that has a sharp edge into a sheetmetal bend that is ready to unfold. 
You select an edge. The function then verifies that it can find an appropriate matching edge 
(the corner on the other side of the sheet), determines the sheet’s thickness, and places 
blends of the appropriate radii on the edges. This forms the inside and outside of the corner. 
The figures below illustrate before and after applying this function.  
 
 
Before: 

 
 
After: 
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Cut Sheetmetal Corner Added to Modify Menu 
Location: Modify>Solid Trim/Break>Cut Sheetmetal Corner. This new function is 
sometime called "sheetmetal tearing." This function cuts away material from a corner of a 
solid so that the adjoining faces can be separated and then unbent along one of their other 
edges. With the dialog for this function, shown below, you can elect to cut a slice parallel to 
one face or the other, or cut away the entire region that makes up the corner. 
 

 
 
The figures below illustrate before and after applying this function.  
 
Before: 
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After: 

 
 
 

Lightweight Functionality Added 
Location: Assemblies>Lightweight; Part Splitter>Part Reference (Lightweight column 
added); Assemblies>Create Reference>open a file>Options tab (check box: Lightweight 
reference for visualization purposes only); Part Splitter>Level Sets (Lightweight 
column added); Part Splitter>Level Sets>Streamed column (for which, see pages 25-26). 
With this release, you can display assemblies in lightweight mode. This is similar to the 
suppressed mode in that the full geometric data of the referenced part is not loaded in 
memory. Instead, a lightweight stream is loaded and displayed. This allows visualization of 
the reference model, without the overhead of the full geometric data. When a part reference 
is lightweight, the geometry exists only in the display and cannot be selected independently 
of the part reference for any operation, including position selection. You can load the full 
geometry data when necessary for operations by turning off the lightweight option for that 
reference. When the operations are completed, you can turn on the lightweight option again. 
Note that dimensions to these references will become suppressed when this is done. To 
display a reference as lightweight so that it has an effect, the referenced level set must have 
the Stream option on. This is optional so that users who do not use the assemblies 
functionality do not incur the additional save time and file size required to maintain the 
lightweight stream in the referenced file. The default level set in each part has this option 
disabled by default. All other level sets have this option enabled by default.  
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In summary, lightweight functionality adds 

 Lightweight function to the Assemblies menu (Assemblies>Lightweight) 
 

 Lightweight column to the Part Reference pane of the Part Splitter (Open Part 
Splitter and click the Part References tab) 

 
 Lightweight to the Part Reference Context Sensitive Menu (Open Part Splitter, 

click Part References tab, then right-click a part reference row) 
 

 Lightweight reference for visualization purposes only check box to Creating a 
New Part Reference dialog (Assemblies>Create Reference, open a file, click 
Options tab) 

 
 Stream column to the Level Sets pane of the Part Splitter (Open Part Splitter, 

click the Level Sets tab) 
 
See File Import Optimization below for relevant information. 
 

ENHANCED FUNCTIONS 
This release enhances several functions, as explained below.  

File Import Optimization 
Location: File>Import. All translations of assemblies (File>Import) that use either 
external or internal part references result in lightweight assemblies. However, when 
necessary for operations like editing, for example, you can load the full geometry by 
clearing the lightweight option. This lightweight option is a check box in the Lightweight 
column in the Part References pane of the Part Splitter. See Lightweight Functionality 
Added on page 9 for relevant information.  

CATIA v5 Import Supports CGR Referenced in an Assembly 
Location: File>Import>Catia v5. With this release, the Catia v5 import function supports the 
translation of Catia v5 CGR files referenced in an assembly. Note that this functionality is not 
supported if the assembly is translated flat. That is, either the Assembly with Internal Part 
References or the Assembly with External Part References option must be selected on the 
following dialog. You can display this dialog by clicking File>Import>Catia v5, then clicking the 
Options button and then the Common Import Options tab. 
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Several Export Functions Allow Selection of Composite Entities 
Location: File>Export …. With this release, the following Export functions allow you to 
select composite entities. The composites are burst into individual entities upon export: 
 
 File>Export>ACIS SAT 
 File>Export>STEP 
 File>Export>Parasolid 
 File>Export>Catia v4 
 File>Export>Catia v5 

 

Several Export Functions Allow Export of Entities 
This release allows you to export one or more entities as HPGL/2, CGM, PDF and U3D, as 
explained below. 

One or More Entities Can Be Exported as HPG/2 
Location: File>Export>HPG/2. With this release, you can export the currently 
visible viewspace to either a HP/GL or HP/GL2 format, as before. But now, you also 
can export one or more selected entities to this format as well. 

One or More Entities Can Be Exported as CGM 
Location: File>Export>CGM. With this release, you can export the currently 
visible viewspace to a Computer Graphics Metafile (CGM),  as before. But now, you 
also can export one or more selected entities to this format as well. 

One or More Entities Can Be Exported as PDF 
Location: File>Export>PDF. This release allows you to export one or more entities 
of geometry as a PDF. If you do not select one or more entities and click Accept, all 
displayed geometry is exported as a PDF, as before this release. 

One or More Entities Can Be Exported as U3D 
Location: File>Export>U3D. With this release, you can export the currently visible 
viewspace as a .u3d file, as before. But now, you also can export one or more 
selected entities to this format as well. 
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PDF and 3D PDF Exports Available for Batch Translation                                               
Location: File>Batch Translator. This release adds PDF and 3D PDF to the Export File 
Type drop down, as shown below. 

 

 

 

 

 

 

 

 

 

Generic Edit of Solid Representation Displays Same Dialog as for 
Solids                                                                           
Location: Edit>Entities>Edit. With this release, the same dialog appears when you 
perform a Generic Edit (Edit>Entities>Edit) on the following objects as the dialog that 
appears when editing solids created by modeling methods. That dialog is shown below. 
Notice the three tabs: Material Physical Properties, Faceting Refinement and Attributes. 
Before this release, only the Attributes tab appeared when you performed a Generic Edit on 
the following objects that were created as a solid representation: 

 Fastener  
 Feature 
 Structural Shapes 
 Mechanical Element 

 
("Created as a solid representation" means the object was created using the Tools>Fastener, 
Tools >Feature, Tools>Structural Shapes or Tools>Mechanical Element function, and 
then selecting the Rep Solid option.) 
 
 
 
 
 
 
 
 

 12



 

 

 

 

 

 

 

 

 

 

 

 

 

 

Set Material Properties Function Now Applies to Shells 
Location: Edit>Entities>Set Material Rendering Properties. With this release, you can 
use the Set Material Properties function to define and apply materials to faces, bodies and 
shells. (Before this release, you could use this function to define and apply materials to faces 
and bodies, but not to shells.) 

Set Material Physical Properties Allows More Selections 
Location: Edit>Entities>Set Material Physical Properties. With this release, the Set 
Material Physical Properties function allows you to select fastener, feature, structural shapes 
and mechanical element objects that were created as a solid representation.  

NC Tool Path Tab Added to Tree Window 
Location: View>Control Bars>Tree Window.  This release adds a fourth tab to the tree 
window, called NC Tool Path. An example of the pane that appears when you click this tab 
is shown below. This tree represents tool paths and tools present in an NC CKD file. 
Through a right click in this tree, you can perform all NC operations otherwise performed 
using Tools>NC menus or the NC palette. For details, see the Tree Window topic in 
KeyCreator Help. 
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Select Entities in Part References as Tools to Generate Splines      
Location: Create>Advanced Splines …. This release enhances the following functions to 
allow you to select entities in part references as tools to generate a spline:          
 

 Create>Advanced Splines>Body/Plane Intersection 
 Create>Advanced Splines>Body/Body Intersection 
 Create>AdvancedSplines>Plane/Surface Intersection 
 Create>Advanced Splines>Surface/Surface Intersection 

Automatic Dimensioning Function Now Allows Generic Edit 
Location: Detail>Automatic Dimensioning. With this release, the Automatic 
Dimensioning function creates an entity so that you can apply the Generic Edit and Generic 
Move functions to the entity.  

Check Box and Field Added to Section View Dialog 
Location: Detail>Section View>Section View. This release adds the Show Scale Note 
check box and the Pattern field to the Section View dialog box, as shown below.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
When you select the Show Scale Note check box, a note indicating the selected scale 
appears under the selection label. The height of the scale note text is one-half the height of 
the selection label text. For example, the user selects "1:1" in the Scale field and selects the 
Show Scale Note check box. The result is illustrated below. KeyCreator places the scale 
note "SCALE 1:1" under the selection label "SECTION A-A." The height of the "SCALE 
1:1" text is one-half the height of the "SECTION" text. 
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The combo box in the Pattern field allows you to select the crosshatch pattern that shows in 
the section view. For example, in the illustration below, the user selected what is termed the 
"marble" pattern.   
 

 

Marble 
Pattern 

Scale 
Note 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Addition of "1" to Roundoff List on Detail Options Dialog 
Location: Detail>Settings>Settings. This release adds a 1 to the Roundoff list for both the 
Fractional Representation and the Feet/Inches Representation. This is for all dimensions. 
The figure below illustrates the 1 in the Roundoff list when Fractional is selected in the 
Representation list. When Fractional or Feet/Inches is selected in the Representation list and 
1 is selected in the Roundoff list, the dimension is rounded-off to the nearest whole number. 
(This is like selecting n in the Precision list after you have selected Decimal in the 
Representation list.)    
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Minimum Element Gap Field Added to Detail Options Dialog 
Location: Detail>Settings>Settings. This release adds the Minimum element gap field 
shown below. The field is for ordinate dimensions only. 
 

 
 
This field allows you to specify how close together to place the text of two or more ordinate 
dimensions. As you can see in the figure below, the gap is measured between the vertical 
edges of adjacent dimension text boxes. (The dashed lines in the figure illustrate where 
dimension text boxes would be if they were on. You can turn on or off dimension text boxes 
in the Tolerance mode field on the Ordinate dimension>Primary units pane of the 
dialog.) 
 

 Minimum element gap = 0 

2.
82

2.
54
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82
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54

 

Minimum element gap = .25 
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Assembly Option Added to Three Assemblies Functions 
Location: Assemblies>Make All Refs Absolute, Assemblies>Make All Refs Relative, 
Assemblies>Substitute Part References. This release adds the Assem button to the 
Conversation Bar of the following three functions on the Assemblies menu: 

 Make All Refs Absolute 
 Make All Refs Relative 
 Substitute Part References 

The Assem button is similar to the All button that appears in the Conversation Bar, except 
that Assem performs the function on the entire assembly. This means that clicking Assem 
performs the function for all of the references in the current part. It also performs the 
function on all parts referenced directly or indirectly by those references, progressing down 
the assembly tree to process all the parts.  
 
 

Mass Properties Allows More Selections 
Location: Tools>Verify>Mass Properties. With this release, the Mass Properties function 
allows you to select fastener, feature, structural shapes and mechanical element objects that 
were created as a solid representation. 

Create BOM Function Now Allows Generic Edit 
Location: Tools>BOM and Table>Create a BOM. With this release, the Create BOM 
function creates an entity so that you can apply the Generic Edit and Generic Move 
functions to the entity.  

BOM Express Function Now Allows Generic Edit 
Location: Tools>BOM and Table>BOM Express. With this release, the BOM Express 
function creates an entity so that you can apply the Generic Edit and Generic Move 
functions to the entity.  

Create a Table of Notes Function Revised 
Location: Tools>BOM and Table>Create a Table of Notes. This release changes the 
Create a Table of Notes function so that it creates a table that is a single entity. This allows 
you to apply the Generic Edit and Generic Move functions to the table after you create it 
with Create a Table of Notes. 
 
When you click Tools>BOM and Table>Create a Table of Notes, the Create a BOM 
Table dialog now appears, as shown below. This has several panes that you can select, using 
a tree arrangement on the left, allowing you to configure the table as desired. For details 
describing each pane, see Create a Table of Notes in KeyCreator Help. 
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"Maximum Number of Entities to Search" Added to Select Pane 
Location: Tools>Options>Select. This release adds the Maximum Number of Entities to 
Search field on the Select pane of the Set Configuration Options dialog, as shown below. 
The purpose of this new field is best understood after understanding the uses of the Search 
Area Radius and Key for Toggling Current Selection fields on this pane. For example, if 
you place the pointer in the vicinity of several entities on the viewport and then repetitively 
press the space bar (as the Key for Toggling Current Selection), KeyCreator highlights the 
entities one-by-one. This can aid you when you need to highlight one entity where there are 
many within a small radius of the pointer location. The radius is set in the Search Area 
Radius field. Before this release, the maximum number of entities that KeyCreator would 
select within the radius was ten. With the Maximum Number of Entities to Search field, 
now you can specify the maximum number of entities (up to 100).  
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Direct 3D Driver Selection Added 
Tools>Options and click Display tab. This release adds Driver3D to the Driver Type drop 
down, as shown below. This allows you to use Direct3D rendering. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

See next 
paragraph. 
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Quick Move Options Added                                                          
Location: Tools>Options>Display. This release adds the three Quick Move check boxes 
shown in the preceding figure: 

 Use Quick Move for non-Entity Animation 
 Use Quick Move for Wireframe Animation 
 Use Quick Move for Solid Animation 

 
Quick Move tells your computer system that changes and screen updates in KeyCreator are 
going to occur quickly. In effect, Quick Move says that it is going to be worthwhile to do 
extra processing to allow moves or deletions to be updated to the screen without the usual 
refreshing of the window.  
 

Each of the three options uses a different algorithm: Exclusive Or (XOR), Overlay, or 
Spriting. With some graphics hardware, some of these options could cause difficulties: 
system crash, incorrect display, …. If this occurs, you would select a different check box.  
Default settings are XOR for non-entity and wireframe animations, and unavailable for solid 
animation. XOR and Overlay cannot be used simultaneously. 

"Apply to Shell" Option Added to Drag and Drop Material 
Location: Parts Splitter Window>Material. This release adds the Apply to Shell check 
box to the menu that appears when you right click the Color, Transparency or Texture 
sphere, as illustrated below. For details on how to apply the properties of a sphere to a part, 
see "Materials Tab" in the Part Splitter Window topic in KeyCreator Help.  
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NEW SDK FUNCTIONS 
To see any new SDK functions for this release, see the SDK Help. To do this, run the install 
program (setup.exe) located in the Debug folder on the Kubotek KeyCreator product CD. 
Then, click the following help file: x/SDK/DOCS/SDK.hlp, where "x" is the install folder. 
Then click the What's New in the KeyCreator.sdk link.  
 

NEW KXL FUNCTIONS 
To see any new KXL functions for this release, see the product’s KXL Help. To do this, 
click Help>Help Topics>KXL Help>What's New>New Functions for KC7.0. 

 

DOCUMENTATION ONLY 
This release makes the following changes or additions that only affect documentation. 

Important Requirement for Windows Vista Users  
If you are running KeyCreator with the Windows Vista operating system, to view 
KeyCreator Help you must install the Windows Help program, whose filename is 
WinHlp32.exe. Follow the download instructions at 
http://support.microsoft.com/kb/917607. This is necessary because the Windows Vista 
operating system does not include WinHlp32.exe, the program necessary to read WinHelp 
files. (Previous Windows operating systems include this file.) 

NC Help Documentation Improved 
Location: Tools>NC …. This release improves the Help index so that you can find NC 
functions more easily. Also, several of the Help topic names for NC functions were not the 
same names as used on the Tools>NC menus, and had no location indicated (like 
"Location: Tools>NC>Launch Metacut"). This release changes such inconveniences so 
you can find Help more quickly for NC functions. 
 
 

MISCELLANEOUS 

Columns Added in Part Splitter 
Location: Part Splitter Window>Part Reference and Part Splitter Window>Level Set. 
See below. This release adds the Hidden and Suppressed columns to the Part Reference 
pane on the Part Splitter. For a description of the unrelated Lightweight column to this 
pane, see Lightweight Functionality Added on page 9.) Also, to the Level Set pane, it adds 
the Streamed column.   
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Hidden Column: 
When a part reference is hidden (check box selected), its visual representation is replaced 
with a bounding cuboid, which retains the color attribute of the hidden part reference. 
  
Suppressed Column: 
When you suppress a part reference (check box selected), it is not only hidden from view. 
Also, the entities belonging to the suppressed part reference are "removed" from the part. 
 
Streamed Column: 
When selected for a level set, the data necessary for lightweight assemblies is saved for that 
level set. When cleared, the lightweight data is not saved with the part. For details, see the 
"Lightweight" topic in Help. 
 
Part Reference Pane: 
  

 

 

 

 

 

 

New. See page 9. New Columns 

 
Level Sets Pane: 

 

 

 

 

 

New Column 

 

 

 24



 

Supported Translators 
The table below identifies the translator versions that KeyCreator 7.0.1 supports. The term 
“to” means “up to and including.” Bold under a column heading indicates a change for this 
release. 
 

File Format Direction Supported File Versions 
Imports as 
Assembly 

File? 
Import ACIS 
Export 

1.5 to R17 N/A 

Import No CATIA V4 Export 4.1.9 to 4.2.4 N/A 
Import V5 R2 to V5 R17 Yes CATIA V5 Export V5 R6 to R17 N/A 
Import All Versions to 2007 No 

DWG/DXF Export R12 to R14, 2000, 2002, 
2004 to 2006 N/A 

Import All Versions to 5.3  Yes IGES Geometry 
Export 5.3 N/A 

AutoDesk Inventor Import Only 6 to 11, 2008 No 
Import 10.0 to 18.0.141 Yes Parasolid Export 12.0 to 18.0.141 N/A 

Pro/ENGINEER Import Only 16 to 2001, Wildfire 1 to 3 Yes 
SolidWorks Import Only 96-2007 Yes  

Import Yes STEP Export AP203, AP214 N/A 
Unigraphics Import Only 11 to 18, NX1 to NX4 Yes 
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New CDE Applications Added 

Bonus KQwinCommand.cde Provided  
Location: Add-Ins>CDE Open>KQwinCommand.cde>Open. This release 
provides you with KQwinCommand.cde as a bonus program. 
KQwinCommand.cde makes available to you many useful Qwins (Quick Windows 
System) commands. 
 
When you install KeyCreator and accept the default locations, KQwinCommand.cde 
is placed in the KeyCreator CDE folder. Also, a PDF document explaining the 
program is placed in the Lang/English folder as Qwins_Commands.pdf.  
 
Once KeyCreator is installed, open KQwinCommand.cde by clicking Add-Ins>CDE 
Open>KQwinCommand.cde>open. The Qwins palette shown below appears to the 
left of the KeyCreator viewport. Click the desired button to display command icons 
for selection. 
 

 
 
If you want the Qwins palette to appear the next time you open KeyCreator, register 
KQwinsCammand.cde as follows: 
 

1. Click Tools>Options>Startup. The Startup pane of the Set Configuration 
Options dialog appears. 

2. Click the New (Insert) button beside "Automatically Loaded CDE(s)." A 
field appears.  

3. Click the browse button and double-click KQwinCommand.cde.  
4. Click OK. 
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Bonus SP_POLYGON Application Provided  
Location: Add-Ins>CDE Open>sp_menu.cde. The SP3D Polygon application 
consists of two CDEs and a resource DLL. You load sp_menu, which is the 
resource-driven CDE. This automatically loads the application sp_pgon.cde. The 
resources are in a separate DLL (sp_pgonRes.dll). 
 
This CDE-based application makes available to you 15 functions. These perform 
many operations, a few of which are   
 Transform point clouds to trigonal polygons 
 Make, modify and transform polygons 
 Convert polygons to shells 
 Get the trigonal polygonal Vertex data for machining (via NC in KeyCreator) 

 
When you install KeyCreator and accept the default locations, both sp_pgon.cde 
and sp_menu.cde are placed in the KeyCreator CDE folder. The resource DLL 
(sp_pgonRes) is placed in the Lang/English folder. A PDF file (SP_Polygons.pdf) 
that explains the program also is placed in Lang/English.  
 
Once KeyCreator is installed, open the application by clicking Add-Ins>CDE 
Open>sp_menu.cde. The palette shown below appears to the left of the KeyCreator 
viewport. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If you want this palette to appear the next time you open KeyCreator, register 
sp_menu.cde as follows: 
 

1. Click Tools>Options>Startup. The Startup pane of the Set Configuration 
Options dialog appears. 

2. Click the New (Insert) button beside "Automatically Loaded CDE(s)." A 
field appears.  

3. Click the browse button and double-click sp_menu.cde.  
4. Click OK. 
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